DigiCert DSM (eSeals) Signing Service Outage

Incident Report for eSignFlow

Resolved

This incident has been resolved.
Posted May 14, 2025 - 17:10 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 15:46 CEST

Identified

We are currently experiencing an outage with the DigiCert DSM (eSeals) signing service. Our team is actively investigating the issue and working to restore full functionality as soon as possible. We apologize for the inconvenience and appreciate your patience.
Posted May 14, 2025 - 13:21 CEST
This incident affected: Signing (DigiCert).