eID signing issues

Incident Report for eSignFlow

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 13:20 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 12:32 CET

Update

We are still waiting for the issue to be resolved. It seems only certificates for old eIDs, those issued by Belgium Root CA3 and Belgium Root CA4 are affected.
Posted Nov 19, 2025 - 17:41 CET

Identified

Due to issues with the certificate revocation services of the Belgian government, we are unable to resolve the revocation status of certain eID cards. Because of this, it is currently impossible to sign using these eID cards. We are working to resolve this as soon as possible.

If you have any questions, please do not hesitate to contact us: helpdesk@esignflow.be
Posted Nov 19, 2025 - 10:44 CET
This incident affected: Signing (eID).